AOT Website Maintenance

Incident Report for Albion Online Tools Status

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 05:00 CEST

Update

The maintenance has been completed. We’ll continue to monitor closely for any issues. Thank you for your patience!
Posted Oct 05, 2025 - 20:21 CEST

Update

The required maintenance is taking longer than expected, we are doing our best to restore everything as quickly as possible.
Posted Oct 05, 2025 - 19:55 CEST

Identified

We're currently undergoing unexpected required maintenance. We’re working to restore everything as quickly as possible
Posted Oct 05, 2025 - 18:12 CEST
This incident affected: Albion Online Tools (Albion Online Tools Web).