Server Status Feature Outage

Incident Report for Albion Online Tools Status

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 03:42 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 17, 2025 - 01:28 CEST

Identified

We are currently experiencing an outage with the server status feature. This feature, which reports on the online/offline status of Albion Online servers, is not updating correctly and may show all servers as offline.
Posted Oct 16, 2025 - 16:44 CEST
This incident affected: Discord (Albion Server Updates).